写真提供:マイナビニュース

写真拡大

Automatticは4月24日(米国時間)、「WordPress 4.8 Will End Support for Internet Explorer Versions 8, 9, and 10 - WordPress Tavern」において、次のリリースが予定されているWordPress 4.8リリースからInternet Explorer 8、Internet Explorer 9、Internet Explorer 10のサポートを終了すると伝えた。Microsoftは2016年1月の段階ですでにこれらブラウザのサポートを終了している。

記事では、StatCounter GlobalStatsの以下の利用シェアを引き合いに出し、サポートが終了するブラウザが利用されている割合がすでに低いことを指摘。

・IE8: 0.41%
・IE9: 0.26%
・IE10: 0.26%
・IE11: 3.79%

これらブラウザでWordPress 4.8以降が直ちに動作しなくなるわけではないが、開発チームは以降のリリースに関してはこれらブラウザでの新機能テストなどを実施しなくなる。特に新しいエディタがこれら古いバージョンのInternet Explorerでは適切に動作しなくなるものと見られる。

セキュリティサポートが終了したブラウザを使い続けることは危険性が伴うため、セキュリティサポートが提供されているブラウザへ移行することが望まれる。

(後藤大地)